Username: Password:
  Create an account Home  ·  Game Manager  ·  Forums  ·  Your Account  
Login
Username

Password

Don't have an account yet? You can create one.

Site Sections
· Home
· Game Manager
· Forums
· Private Messages
· Your Account

Game Manager
· Your games
· Waiting games
· Create new game
· Running games
· Completed games

Recent News

MaBiWeb: Forums

MaBiWeb :: View topic - Nations - Undeploy Worker costs stone? (no bug)
 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Nations - Undeploy Worker costs stone? (no bug)

 
Post new topic   Reply to topic    MaBiWeb Forum Index -> Bug reports
View previous topic :: View next topic  
Author Message
FriedEgg



Joined: Jul 13, 2017
Posts: 3

PostPosted: Tue Dec 12, 2017 9:36 am    Post subject: Nations - Undeploy Worker costs stone? (no bug) Reply with quote

In a recent game of Nations (currently in progress) it wanted to charge me 1 stone to undeploy a worker from a military building. This is incorrect according to the rules. It should always be free to undeploy. So I think this must be a bug?
Back to top
View user's profile Send private message
B_Factor



Joined: Jan 21, 2017
Posts: 80

PostPosted: Tue Dec 12, 2017 11:43 am    Post subject: Re: Nations - Undeploy Worker costs stone? Reply with quote

FriedEgg wrote:
In a recent game of Nations (currently in progress) it wanted to charge me 1 stone to undeploy a worker from a military building. This is incorrect according to the rules. It should always be free to undeploy. So I think this must be a bug?

A couple of tips:

1. Including the game ID helps MaBi investigate possible bugs.

2. You posted this in the "Bug reports" forum, which is designated for "General site bugs (not game specific)"; posting in the Nations forum would have been better.
Back to top
View user's profile Send private message
MaBi
Site Admin


Joined: Jan 01, 2006
Posts: 864
Location: Italy

PostPosted: Tue Dec 12, 2017 4:44 pm    Post subject: Reply with quote

Such an obvious bug after all these games? It seems very unlikely, nobody ever reported a problem in the undeploy action.
What's the game id?
Did you complete the action (so it should be there and I can check the log) or did you cancel before confirming?
Back to top
View user's profile Send private message Visit poster's website
MaBi
Site Admin


Joined: Jan 01, 2006
Posts: 864
Location: Italy

PostPosted: Tue Dec 12, 2017 4:55 pm    Post subject: Reply with quote

I think I found the game (66935, your only running game).
Looking at the log you did only one undeploy action (undeploy from Hoplite, at the end of round 3), and you didn't pay anything for it: you had 7 stones at the beginning of the round, spent 2 for Alhambra, 1 to deploy a worker on Brewery, then you undeployed from Hoplite and deployed to Quarry paying 1 stone, and finished your action phase with 3 stones. From the log everything looks correct.
Back to top
View user's profile Send private message Visit poster's website
FriedEgg



Joined: Jul 13, 2017
Posts: 3

PostPosted: Tue Dec 12, 2017 7:06 pm    Post subject: Reply with quote

Apologies for posting in the wrong forum.

I was going to undeploy the last worker from the Hoplite when I noticed it cost me 1 stone to do so so I never confirmed the action and did something else instead (since I needed all my remaining stone to do something else). Which is why you wouldn't have seen it in the log.

I shall try it again soon and report back if it still seems to be a problem.
Back to top
View user's profile Send private message
MaBi
Site Admin


Joined: Jan 01, 2006
Posts: 864
Location: Italy

PostPosted: Tue Dec 12, 2017 8:41 pm    Post subject: Reply with quote

Yes please: should it happen again leave the game as it is, without taking any move, and let me know so I can have a look!
(Knowing the code, I still doubt there could be such a bug and I think you mis-clicked something. Were you playing on a phone or tablet? Maybe you accidentally touched the "deploy" link on some card and that would explain the spending of a stone. Anyway, let me know if it happens again, thank you!)
Back to top
View user's profile Send private message Visit poster's website
FriedEgg



Joined: Jul 13, 2017
Posts: 3

PostPosted: Wed Dec 13, 2017 11:13 am    Post subject: Reply with quote

Ah yes, I think I have to apologise, it isn't a bug. I was trying to undeploy a worker by clicking on the coal symbol at the bottom corner of the building rather than on the worker in the middle.

Please consider the matter closed.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    MaBiWeb Forum Index -> Bug reports All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2005 phpBB Group
Forums ©

 
MaBiWeb copyright 2006 by MaBi
PHP-Nuke Copyright © 2005 by Francisco Burzi.
Page Generation: 0.10 Seconds